glibc-devel-2.20-8pclos2016.x86_64.rpm


Advertisement

Description

glibc-devel - Header and object files for development using standard C libraries

Distribution: PCLinuxOS
Repository: PCLinuxOS x86_64
Package name: glibc-devel
Package version: 2.20
Package release: 8pclos2016
Package architecture: x86_64
Package type: rpm
Installed size: 5.06 MB
Download size: 5.06 MB
Official Mirror: ftp.nluug.nl
The glibc-devel package contains the header and object files necessary for developing programs which use the standard C libraries (which are used by nearly all programs). If you are developing programs which will use the standard C libraries, your system needs to have these standard header and object files available in order to create the executables. This package also includes the C header files for the Linux kernel. The header files define structures and constants that are needed for building most standard programs. The header files are also needed for rebuilding the kernel. Install glibc-devel if you are going to develop programs which will use the standard C libraries.

Alternatives

Requires

Provides

  • devel(libBrokenLocale(64bit))
  • devel(libBrokenLocale)
  • devel(libanl(64bit))
  • devel(libanl)
  • devel(libcidn(64bit))
  • devel(libcidn)
  • devel(libcrypt(64bit))
  • devel(libcrypt)
  • devel(libdl(64bit))
  • devel(libdl)
  • devel(libm(64bit))
  • devel(libm)
  • devel(libnsl(64bit))
  • devel(libnsl)
  • devel(libnss_compat(64bit))
  • devel(libnss_compat)
  • devel(libnss_db(64bit))
  • devel(libnss_db)
  • devel(libnss_dns(64bit))
  • devel(libnss_dns)
  • devel(libnss_files(64bit))
  • devel(libnss_files)
  • devel(libnss_hesiod(64bit))
  • devel(libnss_hesiod)
  • devel(libnss_nis(64bit))
  • devel(libnss_nis)
  • devel(libnss_nisplus(64bit))
  • devel(libnss_nisplus)
  • devel(libresolv(64bit))
  • devel(libresolv)
  • devel(librt(64bit))
  • devel(librt)
  • devel(libthread_db(64bit))
  • devel(libthread_db)
  • devel(libutil(64bit))
  • devel(libutil)
  • glibc-crypt_blowfish-devel = 1.2
  • glibc-devel = 2.20-8pclos2016
  • glibc-devel(x86-64) = 2.20-8pclos2016

Obsoletes

  • glibc-debug < 2.3.2-15
  • libc-debug
  • libc-devel
  • libc-headers
  • linuxthreads-devel
  • nptl-devel

    Install Howto

    1. Enable PCLinuxOS x86_64 repository in /etc/apt/sources.list:
      rpm http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/ pclinuxos/64bit x86_64
      
    2. Update the package index:
      # apt-get update
    3. Install glibc-devel rpm package:
      # apt-get install glibc-devel
    Advertisement
    Advertisement