gpac-0.5.0-4pclos2015.x86_64.rpm


Advertisement

Description

gpac - MPEG-4 multimedia framework

Property Value
Distribution PCLinuxOS
Repository PCLinuxOS x86_64
Package name gpac
Package version 0.5.0
Package release 4pclos2015
Package architecture x86_64
Package type rpm
Installed size 5.97 MB
Download size 5.97 MB
Official Mirror ftp.nluug.nl
GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
from scratch in ANSI C.  The original development goal is to provide a clean
(a.k.a. readable by as many people as possible), small and flexible
alternative to the MPEG-4 Systems reference software.
The natural evolution has been the integration of recent multimedia standards
(SVG/SMIL, VRML, X3D, SWF, 3GPP(2) tools, etc) into a single framework.
VRML97 and a good amount of the X3D standard have already been integrated
into GPAC, as well as some SVG support and experimental Macromedia Flash
support.
The current GPAC release (0.4.0) already covers a very large part of the
MPEG-4 standard, and has some good support for 3GPP and VRML/X3D, and
features what can probably be seen as the most advanced and robust 2D MPEG-4
Player available worldwide, as well as a decent 3D player.
GPAC also features MPEG-4 Systems encoders/multiplexers, publishing tools for
content distribution for MP4 and 3GPP(2) files and many tools for scene
descriptions (MPEG4<->VRML<->X3D converters, SWF->MPEG-4, etc...).

Alternatives

Package Version Architecture Repository
gpac - - -

Requires

Name Value
glibc >= 2.20
libGL.so.1()(64bit) -
libGLU.so.1()(64bit) -
libSDL-1.2.so.0()(64bit) -
libX11.so.6()(64bit) -
libXext.so.6()(64bit) -
libXv.so.1()(64bit) -
liba52.so.0()(64bit) -
libasound.so.2()(64bit) -
libavcodec.so.56()(64bit) -
libavformat.so.56()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.11)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libc.so.6(GLIBC_2.8)(64bit) -
libcrypto.so.1.0.0()(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libfaad.so.2()(64bit) -
libfreetype.so.6()(64bit) -
libgpac.so.2()(64bit) -
libjack.so.0()(64bit) -
libjpeg.so.8()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libmad.so.0()(64bit) -
libogg.so.0()(64bit) -
libopenjpeg.so.5()(64bit) -
libpng12.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpulse-simple.so.0()(64bit) -
libpulse.so.0()(64bit) -
libssl.so.1.0.0()(64bit) -
libswscale.so.3()(64bit) -
libtheora.so.0()(64bit) -
libvorbis.so.0()(64bit) -
libxvidcore.so.4()(64bit) -
libz.so.1()(64bit) -
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsLzma) <= 4.4.6-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rtld(GNU_HASH) -

Provides

Name Value
gm_aac_in.so()(64bit) -
gm_ac3_in.so()(64bit) -
gm_alsa.so()(64bit) -
gm_audio_filter.so()(64bit) -
gm_bifs_dec.so()(64bit) -
gm_ctx_load.so()(64bit) -
gm_dummy_in.so()(64bit) -
gm_ffmpeg_in.so()(64bit) -
gm_ft_font.so()(64bit) -
gm_img_in.so()(64bit) -
gm_ismacryp.so()(64bit) -
gm_isom_in.so()(64bit) -
gm_jack.so()(64bit) -
gm_laser_dec.so()(64bit) -
gm_mp3_in.so()(64bit) -
gm_mpd_in.so()(64bit) -
gm_mpegts_in.so()(64bit) -
gm_odf_dec.so()(64bit) -
gm_ogg_xiph.so()(64bit) -
gm_osd.so()(64bit) -
gm_oss_audio.so()(64bit) -
gm_pulseaudio.so()(64bit) -
gm_rtp_in.so()(64bit) -
gm_saf_in.so()(64bit) -
gm_sdl_out.so()(64bit) -
gm_soft_raster.so()(64bit) -
gm_svg_in.so()(64bit) -
gm_timedtext.so()(64bit) -
gm_widgetman.so()(64bit) -
gm_x11_out.so()(64bit) -
gm_xvid_dec.so()(64bit) -
gpac = 0.5.0-4pclos2015
gpac(x86-64) = 0.5.0-4pclos2015
libgpac.so.2()(64bit) -

Obsoletes

Name Value
Osmo4 < 0.5.0

Download

Type URL
Binary Package gpac-0.5.0-4pclos2015.x86_64.rpm
Source Package gpac-0.5.0-4pclos2015.src.rpm

Install Howto

  1. Enable PCLinuxOS x86_64 repository in /etc/apt/sources.list:
    
    rpm http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/ pclinuxos/64bit x86_64
    
  2. Update the package index:
    # apt-get update
  3. Install gpac rpm package:
    # apt-get install gpac

See Also

Package Description
gpac-devel-0.5.0-4pclos2015.x86_64.rpm Static library from gpac
gparted-0.27.0-1pclos2016.x86_64.rpm Graphical frontend to libparted
gperf-3.0.3-1pclos2011.x86_64.rpm A perfect hash function generator
gphoto2-2.5.10-2pclos2017.x86_64.rpm Command line utilities to access digital cameras
gpick-0.2.4-1pclos2014.x86_64.rpm GPick is a advanced color picker
gpicview-0.2.5-1pclos2016.x86_64.rpm A very simple, fast, and lightweight image viewer featuring immediate startup
gpixpod-0.6.2-5pclos2013.x86_64.rpm Photo manager for capable iPods
gpm-1.20.7-1pclos2017.x86_64.rpm A mouse server for the Linux console
gpodder-3.8.2-1pclos2014.noarch.rpm A graphical podcast catcher
gprolog-1.3.1-1pclos2011.x86_64.rpm GNU Prolog is a free implementation of Prolog
gpsbabel-1.5.0-1pclos2014.x86_64.rpm GPSBabel converts GPS data from one format to another
gpsbabel-gui-1.5.0-1pclos2014.x86_64.rpm Qt GUI interface for GPSBabel
gpscorrelate-1.6.1-1pclos2011.x86_64.rpm GPS photo tagging application
gpsd-2.95-2pclos2013.x86_64.rpm GPS data translator and GUI
gpsd-clients-2.95-2pclos2013.x86_64.rpm Clients for gpsd with an X interface
Advertisement
Advertisement