lib64ffi6-3.2.1-1pclos2016.x86_64.rpm


Advertisement

Description

lib64ffi6 - A portable foreign function interface library

Property Value
Distribution PCLinuxOS
Repository PCLinuxOS x86_64
Package name lib64ffi6
Package version 3.2.1
Package release 1pclos2016
Package architecture x86_64
Package type rpm
Installed size 51.16 KB
Download size 51.16 KB
Official Mirror ftp.nluug.nl
Compilers for high level languages generate code that follow certain
conventions.  These conventions are necessary, in part, for separate
compilation to work.  One such convention is the "calling convention".
The calling convention is a set of assumptions made by the compiler
about where function arguments will be found on entry to a function.
A calling convention also specifies where the return value for a function
is found.
Some programs may not know at the time of compilation what arguments
are to be passed to a function.  For instance, an interpreter may be
told at run-time about the number and types of arguments used to call
a given function.  `Libffi' can be used in such programs to provide
a bridge from the interpreter program to compiled code.
The `libffi' library provides a portable, high level programming
interface to various calling conventions.  This allows a programmer to
call any function specified by a call interface description at run time.
FFI stands for Foreign Function Interface.  A foreign function
interface is the popular name for the interface that allows code
written in one language to call code written in another language.
The `libffi' library really only provides the lowest, machine dependent
layer of a fully featured foreign function interface.  A layer must
exist above `libffi' that handles type conversions for values passed
between the two languages.

Alternatives

Package Version Architecture Repository
lib64ffi6 - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rtld(GNU_HASH) -

Provides

Name Value
lib64ffi6 = 3.2.1-1pclos2016
lib64ffi6(x86-64) = 3.2.1-1pclos2016
libffi = 3.2.1-1pclos2016
libffi.so.6()(64bit) -
libffi6 = 3.2.1-1pclos2016

Download

Type URL
Binary Package lib64ffi6-3.2.1-1pclos2016.x86_64.rpm
Source Package libffi-3.2.1-1pclos2016.src.rpm

Install Howto

  1. Enable PCLinuxOS x86_64 repository in /etc/apt/sources.list:
    
    rpm http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/ pclinuxos/64bit x86_64
    
  2. Update the package index:
    # apt-get update
  3. Install lib64ffi6 rpm package:
    # apt-get install lib64ffi6

See Also

Package Description
lib64ffmpeg-devel-2.8.10-1pclos2017.x86_64.rpm Header files for the ffmpeg codec library
lib64ffmpeg-static-devel-2.8.10-1pclos2017.x86_64.rpm Static library for the ffmpeg codec library
lib64ffmpegthumbnailer-devel-2.0.10-1pclos2015.x86_64.rpm Development files for ffmpegthumbnailer
lib64ffmpegthumbnailer4-2.0.10-1pclos2015.x86_64.rpm Main library for ffmpegthumbnailer
lib64ffms2-devel-2.22-1pclos2016.x86_64.rpm Development package for ffms2
lib64ffms2_4-2.22-1pclos2016.x86_64.rpm Library for ffms2
lib64fftw-devel-3.3.4-1pclos2016.x86_64.rpm Headers, libraries, & docs for the FFTW fast Fourier transform library
lib64fftw-static-devel-3.3.4-1pclos2016.x86_64.rpm Static development files for the FFTW fast Fourier transform library
lib64fftw3-3.3.4-1pclos2016.x86_64.rpm Fast Fourier transform library
lib64fftwmpi3-3.3.4-1pclos2016.x86_64.rpm MPI-parallel fast Fourier transform library
lib64fftwomp3-3.3.4-1pclos2016.x86_64.rpm OpenMP-parallel fast Fourier transform library
lib64filezilla-devel-0.6.1-1pclos2016.x86_64.rpm Development package for libfilezilla
lib64filezilla0-0.6.1-1pclos2016.x86_64.rpm Small and modern C++ library
lib64flac++6-1.3.2-1pclos2017.x86_64.rpm Shared C++ libraries for FLAC
lib64flac++6-devel-1.3.2-1pclos2017.x86_64.rpm Libraries and headers needed for building apps using FLAC++
Advertisement
Advertisement