lib64gtk+2.0_0-devel-2.24.31-1pclos2016.x86_64.rpm


Advertisement

Description

lib64gtk+2.0_0-devel - Development files for GTK+ (GIMP ToolKit) applications

Property Value
Distribution PCLinuxOS
Repository PCLinuxOS x86_64
Package name lib64gtk+2.0_0-devel
Package version 2.24.31
Package release 1pclos2016
Package architecture x86_64
Package type rpm
Installed size 9.16 MB
Download size 9.16 MB
Official Mirror ftp.nluug.nl
The libgtk+-devel package contains the static libraries and header files
needed for developing GTK+ (GIMP ToolKit) applications. The libgtk+-devel
package contains GDK (the General Drawing Kit, which simplifies the interface
for writing GTK+ widgets and using GTK+ widgets in applications), and GTK+
(the widget set).

Alternatives

Package Version Architecture Repository
lib64gtk+2.0_0-devel - - -

Requires

Name Value
devel(libX11(64bit)) -
devel(libXcomposite(64bit)) -
devel(libXcursor(64bit)) -
devel(libXdamage(64bit)) -
devel(libXext(64bit)) -
devel(libXfixes(64bit)) -
devel(libXi(64bit)) -
devel(libXinerama(64bit)) -
devel(libXrandr(64bit)) -
devel(libXrender(64bit)) -
devel(libatk-1.0(64bit)) -
devel(libcairo(64bit)) -
devel(libfontconfig(64bit)) -
devel(libgdk-x11-2.0(64bit)) -
devel(libgdk_pixbuf-2.0(64bit)) -
devel(libgio-2.0(64bit)) -
devel(libglib-2.0(64bit)) -
devel(libgmodule-2.0(64bit)) -
devel(libgobject-2.0(64bit)) -
devel(libm(64bit)) -
devel(libpango-1.0(64bit)) -
devel(libpangocairo-1.0(64bit)) -
devel(libpangoft2-1.0(64bit)) -
lib64gtk+-x11-2.0_0 = 2.24.31
lib64gtk+2.0_0 = 2.24.31
libatk1.0-devel >= 1.29.2
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libcairo.so.2()(64bit) -
libgdk-x11-2.0.so.0()(64bit) -
libgdk_pixbuf-2.0.so.0()(64bit) -
libgdk_pixbuf2.0-devel >= 2.26.0
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-x11-2.0.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpango-1.0.so.0()(64bit) -
libpango1.0-devel >= 1.20.0
libpangocairo-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
pkgconfig -
pkgconfig(atk) -
pkgconfig(cairo) -
pkgconfig(gdk-pixbuf-2.0) -
pkgconfig(gdk-x11-2.0) -
pkgconfig(gio-2.0) -
pkgconfig(gmodule-2.0) -
pkgconfig(gtk+-x11-2.0) -
pkgconfig(pango) -
pkgconfig(pangocairo) -
pkgconfig(pangoft2) -
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rtld(GNU_HASH) -

Provides

Name Value
devel(libgdk-x11-2.0(64bit)) -
devel(libgtk-x11-2.0(64bit)) -
gtk+2-devel = 2.24.31-1pclos2016
gtk2-devel = 2.24.31-1pclos2016
lib64gtk+-x11-2.0_0-devel = 2.24.31-1pclos2016
lib64gtk+2.0_0-devel = 2.24.31-1pclos2016
lib64gtk+2.0_0-devel(x86-64) = 2.24.31-1pclos2016
libgtk+-x11-2.0-devel = 2.24.31-1pclos2016
libgtk+2-devel = 2.24.31-1pclos2016
libgtk+2.0-devel = 2.24.31-1pclos2016
pkgconfig(gdk-2.0) = 2.24.31
pkgconfig(gdk-x11-2.0) = 2.24.31
pkgconfig(gtk+-2.0) = 2.24.31
pkgconfig(gtk+-unix-print-2.0) = 2.24.31
pkgconfig(gtk+-x11-2.0) = 2.24.31

Obsoletes

Name Value
gtk+2-devel -
lib64gtk+-x11-2.0_0-devel -
lib64gtk+2.0_0-devel -
libgtk+2-devel -

Download

Type URL
Binary Package lib64gtk+2.0_0-devel-2.24.31-1pclos2016.x86_64.rpm
Source Package gtk+2.0-2.24.31-1pclos2016.src.rpm

Install Howto

  1. Enable PCLinuxOS x86_64 repository in /etc/apt/sources.list:
    rpm http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/ pclinuxos/64bit x86_64
  2. Update the package index:
    # apt-get update
  3. Install lib64gtk+2.0_0-devel rpm package:
    # apt-get install lib64gtk+2.0_0-devel

See Also

Package Description
lib64gtk+3.0-devel-3.22.7-1pclos2017.x86_64.rpm Development files for GTK+ (GIMP ToolKit) applications
lib64gtk+3_0-3.22.7-1pclos2017.x86_64.rpm The GIMP ToolKit (GTK+), a library for creating GUIs
lib64gtk-vnc1.0-devel-0.5.4-1pclos2016.x86_64.rpm A VNC viewer widget for GTK
lib64gtk-vnc1.0_0-0.5.4-1pclos2016.x86_64.rpm A VNC viewer widget for GTK
lib64gtk-vnc2.0-devel-0.5.4-1pclos2016.x86_64.rpm Headers and development library for gtk3-vnc
lib64gtk-vnc2.0_0-0.5.4-1pclos2016.x86_64.rpm A VNC viewer widget for GTK3
lib64gtkdatabox-devel-0.9.1.3-1pclos2012.x86_64.rpm Development files for gtkdatabox
lib64gtkdatabox0.9.1_3-0.9.1.3-1pclos2012.x86_64.rpm A Gtk+-Widget for Fast Data Display
lib64gtkglarea-devel-2.0.1-3pclos2014.x86_64.rpm Includes and static libs
lib64gtkglarea2.0-2.0.1-3pclos2014.x86_64.rpm OpenGL widget for GTK+ GUI toolkit
lib64gtkglarea5-1.2.3-10pclos2011.x86_64.rpm GtkGLArea is an OpenGL widget for GTK+ GUI toolkit
lib64gtkglarea5-devel-1.2.3-10pclos2011.x86_64.rpm GtkGLArea is an OpenGL widget for GTK+ -- includes and static libs
lib64gtkglext-1.0_0-1.2.0-4pclos2014.x86_64.rpm OpenGL extension to GTK 2.0 or later
lib64gtkglext-devel-1.2.0-4pclos2014.x86_64.rpm OpenGL extension to GTK 2.0 or later
lib64gtkhotkey-devel-0.2.1-1pclos2014.x86_64.rpm Development files for gtkhotkey
Advertisement
Advertisement