lib64openscenegraph-devel-3.4.0-1pclos2016.x86_64.rpm


Advertisement

Description

lib64openscenegraph-devel - OpenSceneGraph development files

Property Value
Distribution PCLinuxOS
Repository PCLinuxOS x86_64
Package name lib64openscenegraph-devel
Package version 3.4.0
Package release 1pclos2016
Package architecture x86_64
Package type rpm
Installed size 3.45 MB
Download size 3.45 MB
Official Mirror ftp.nluug.nl
The OpenSceneGraph is an OpenSource, cross platform graphics
toolkit for the development of high performance graphics
applications such as flight simulators, games, virtual reality
and scientific visualization. Based around the concept of a
SceneGraph, it provides an object oriented framework on top of
OpenGL freeing the developer from implementing and optimizing
low level graphics calls, and provides many additional
utilities for rapid development of graphics applications.
This package contains the header and development files for
OpenSceneGraph.

Alternatives

Package Version Architecture Repository
lib64openscenegraph-devel - - -

Requires

Name Value
devel(libGL(64bit)) -
devel(libOpenThreads(64bit)) -
devel(libQt5Core(64bit)) -
devel(libQt5Gui(64bit)) -
devel(libQt5OpenGL(64bit)) -
devel(libQt5Widgets(64bit)) -
devel(libX11(64bit)) -
devel(libXrandr(64bit)) -
devel(libdl(64bit)) -
devel(libgcc_s(64bit)) -
devel(libm(64bit)) -
devel(libosg(64bit)) -
devel(libosgDB(64bit)) -
devel(libosgFX(64bit)) -
devel(libosgGA(64bit)) -
devel(libosgManipulator(64bit)) -
devel(libosgText(64bit)) -
devel(libosgUI(64bit)) -
devel(libosgUtil(64bit)) -
devel(libosgViewer(64bit)) -
devel(libosgVolume(64bit)) -
devel(libstdc++(64bit)) -
devel(libz(64bit)) -
lib64openscenegraph130 >= 3.4.0-1pclos2016
lib64openthreads-devel >= 3.4.0-1pclos2016
pkgconfig -
pkgconfig(openscenegraph-osg) -
pkgconfig(openscenegraph-osgDB) -
pkgconfig(openscenegraph-osgGA) -
pkgconfig(openscenegraph-osgText) -
pkgconfig(openscenegraph-osgUtil) -
pkgconfig(openscenegraph-osgViewer) -
pkgconfig(openscenegraph-osgWidget) -
pkgconfig(openthreads) -
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rpmlib(VersionedDependencies) <= 3.0.3-1

Provides

Name Value
OpenSceneGraph-devel = 3.4.0-1pclos2016
devel(libosg(64bit)) -
devel(libosgAnimation(64bit)) -
devel(libosgDB(64bit)) -
devel(libosgFX(64bit)) -
devel(libosgGA(64bit)) -
devel(libosgManipulator(64bit)) -
devel(libosgParticle(64bit)) -
devel(libosgPresentation(64bit)) -
devel(libosgQt(64bit)) -
devel(libosgShadow(64bit)) -
devel(libosgSim(64bit)) -
devel(libosgTerrain(64bit)) -
devel(libosgText(64bit)) -
devel(libosgUI(64bit)) -
devel(libosgUtil(64bit)) -
devel(libosgViewer(64bit)) -
devel(libosgVolume(64bit)) -
devel(libosgWidget(64bit)) -
lib64openscenegraph-devel = 3.4.0-1pclos2016
lib64openscenegraph-devel(x86-64) = 3.4.0-1pclos2016
openscenegraph-devel = 3.4.0-1pclos2016
pkgconfig(openscenegraph) = 3.4.0
pkgconfig(openscenegraph-osg) = 3.4.0
pkgconfig(openscenegraph-osgAnimation) = 3.4.0
pkgconfig(openscenegraph-osgDB) = 3.4.0
pkgconfig(openscenegraph-osgFX) = 3.4.0
pkgconfig(openscenegraph-osgGA) = 3.4.0
pkgconfig(openscenegraph-osgManipulator) = 3.4.0
pkgconfig(openscenegraph-osgParticle) = 3.4.0
pkgconfig(openscenegraph-osgQt) = 3.4.0
pkgconfig(openscenegraph-osgShadow) = 3.4.0
pkgconfig(openscenegraph-osgSim) = 3.4.0
pkgconfig(openscenegraph-osgTerrain) = 3.4.0
pkgconfig(openscenegraph-osgText) = 3.4.0
pkgconfig(openscenegraph-osgUtil) = 3.4.0
pkgconfig(openscenegraph-osgViewer) = 3.4.0
pkgconfig(openscenegraph-osgVolume) = 3.4.0
pkgconfig(openscenegraph-osgWidget) = 3.4.0

Obsoletes

Name Value
lib64OpenSceneGraph-devel < 3.2.0-3

Download

Type URL
Binary Package lib64openscenegraph-devel-3.4.0-1pclos2016.x86_64.rpm
Source Package openscenegraph-3.4.0-1pclos2016.src.rpm

Install Howto

  1. Enable PCLinuxOS x86_64 repository in /etc/apt/sources.list:
    rpm http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/ pclinuxos/64bit x86_64
  2. Update the package index:
    # apt-get update
  3. Install lib64openscenegraph-devel rpm package:
    # apt-get install lib64openscenegraph-devel

See Also

Package Description
lib64openscenegraph130-3.4.0-1pclos2016.x86_64.rpm Shared libraries for OpenSceneGraph
lib64openshot-audio-devel-0.1.2-1pclos2017.x86_64.rpm Development files for libopenshot-audio
lib64openshot-audio3-0.1.2-1pclos2017.x86_64.rpm OpenShot Audio Library
lib64openslp-devel-1.2.1-6pclos2013.x86_64.rpm Development tools for programs which will use the openslp library
lib64openslp1-1.2.1-6pclos2013.x86_64.rpm OpenSLP implementation of Service Location Protocol V2
lib64openssl-devel-1.0.2k-1pclos2017.x86_64.rpm Secure Sockets Layer communications libs & headers & utils
lib64openssl-engines1.0.0-1.0.2k-1pclos2017.x86_64.rpm Engines for openssl
lib64openssl-static-devel-1.0.2k-1pclos2017.x86_64.rpm Secure Sockets Layer communications static libs
lib64openssl0.9.8-0.9.8r-1pclos2011.x86_64.rpm Secure Sockets Layer communications libs
lib64openssl1.0.0-1.0.2k-1pclos2017.x86_64.rpm Secure Sockets Layer communications libs
lib64opensync0-0.22-6pclos2014.x86_64.rpm Dynamic libraries from libopensync
lib64opensync0-devel-0.22-6pclos2014.x86_64.rpm Header files and static libraries from libopensync
lib64openthreads-devel-3.4.0-1pclos2016.x86_64.rpm Development package for OpenThreads
lib64openthreads20-3.4.0-1pclos2016.x86_64.rpm A lightweight C++ thread API
lib64opus-devel-1.1.1-1pclos2016.x86_64.rpm Files needed to compile a program with Opus support
Advertisement
Advertisement