lib64qt5lockedfile1-2.4.1-1pclos2016.x86_64.rpm


Advertisement

Description

lib64qt5lockedfile1 - QFile extension with advisory locking functions

Property Value
Distribution PCLinuxOS
Repository PCLinuxOS x86_64
Package name lib64qt5lockedfile1
Package version 2.4.1
Package release 1pclos2016
Package architecture x86_64
Package type rpm
Installed size 14.17 KB
Download size 14.17 KB
Official Mirror ftp.nluug.nl
This class extends the QFile class with inter-process file locking capabilities.
If an application requires that several processes should access the same file,
QtLockedFile can be used to easily ensure that only one process at a time is
writing to the file, and that no process is writing to it while others are
reading it.
This is the library package for qtlockedfile

Alternatives

Package Version Architecture Repository
lib64qt5lockedfile1 - - -

Requires

Name Value
libQt5Core.so.5()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH) -

Provides

Name Value
lib64qt5lockedfile1 = 2.4.1-1pclos2016
lib64qt5lockedfile1(x86-64) = 2.4.1-1pclos2016
libQt5Solutions_LockedFile-2.4.so.1()(64bit) -

Download

Type URL
Binary Package lib64qt5lockedfile1-2.4.1-1pclos2016.x86_64.rpm
Source Package qtlockedfile-2.4.1-1pclos2016.src.rpm

Install Howto

  1. Enable PCLinuxOS x86_64 repository in /etc/apt/sources.list:
    
    rpm http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/ pclinuxos/64bit x86_64
    
  2. Update the package index:
    # apt-get update
  3. Install lib64qt5lockedfile1 rpm package:
    # apt-get install lib64qt5lockedfile1

See Also

Package Description
lib64qt5multimedia-devel-5.6.2-1pclos2016.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5multimedia5-5.6.2-1pclos2016.x86_64.rpm Qt5 Lib
lib64qt5multimediaquick_p-devel-5.6.2-1pclos2016.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5multimediaquick_p5-5.6.2-1pclos2016.x86_64.rpm Qt5 Lib
lib64qt5multimediawidgets-devel-5.6.2-1pclos2016.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5multimediawidgets5-5.6.2-1pclos2016.x86_64.rpm Qt5 Lib
lib64qt5network-devel-5.6.2-2pclos2016.x86_64.rpm Devel files needed to build apps based on QtNetwork
lib64qt5network5-5.6.2-2pclos2016.x86_64.rpm Qt5 Component Library
lib64qt5nfc-devel-5.6.2-1pclos2016.x86_64.rpm Devel files needed to build apps based on QtNfc
lib64qt5nfc5-5.6.2-1pclos2016.x86_64.rpm Qt5 Component Library
lib64qt5opengl-devel-5.6.2-2pclos2016.x86_64.rpm Devel files needed to build apps based on QtContacts
lib64qt5opengl5-5.6.2-2pclos2016.x86_64.rpm Qt5 Component Library
lib64qt5platformsupport-devel-5.6.2-2pclos2016.x86_64.rpm Devel files needed to build apps based on QtPlatformSupport
lib64qt5positioning-devel-5.6.2-1pclos2016.x86_64.rpm Devel files needed to build apps based on QtPositioning
lib64qt5positioning5-5.6.2-1pclos2016.x86_64.rpm Qt5 Component Library
Advertisement
Advertisement