perl-Period-1.20-10pclos2011.noarch.rpm


Advertisement

Description

perl-Period - Time::Period module for perl

Property Value
Distribution PCLinuxOS
Repository PCLinuxOS x86_64
Package filename perl-Period-1.20-10pclos2011.noarch.rpm
Package name perl-Period
Package version 1.20
Package release 10pclos2011
Package architecture noarch
Package type rpm
Homepage -
License -
Maintainer -
Download size 35.70 KB
Installed size 35.70 KB
Period.pm is a Perl module that contains code to deal with time periods.
Currently, there is only a function in this module.  That function is
called inPeriod().
inPeriod() determines if a given time is within a given time period.
It will return 1 if it is, 0 if not, and -1 if either the time or the
period passed to it were malformed.  The time is specified in non-leap
year seconds past January 1, 1970, as per the time() function.  The period
is a string which is of the form described in Period's man page.

Alternatives

Package Version Architecture Repository
perl-Period - - -

Requires

Name Value
perl(Exporter) -
perl-base >= 5.12.3
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsLzma) <= 4.4.6-1
rpmlib(VersionedDependencies) <= 3.0.3-1

Provides

Name Value
perl(Time::Period) = 1.200.0
perl-Period = 1.20-10pclos2011

Download

Type URL
Mirror ftp.nluug.nl
Binary Package perl-Period-1.20-10pclos2011.noarch.rpm
Source Package perl-Period-1.20-10pclos2011.src.rpm

Install Howto

  1. Enable PCLinuxOS x86_64 repository in /etc/apt/sources.list:
    rpm http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/ pclinuxos/64bit x86_64
  2. Update the package index:
    # apt-get update
  3. Install perl-Period rpm package:
    # apt-get install perl-Period

See Also

Package Description
perl-Perl-AtEndOfScope-0.03-10pclos2011.noarch.rpm Perl::AtEndOfScope - run some code when a variable goes out of scope
perl-Perl-BestPractice-0.01-10pclos2011.noarch.rpm Perl Best Practices, the (unofficial) companion module
perl-Perl-Critic-1.105-10pclos2011.noarch.rpm Critique Perl source for style and standards
perl-Perl-MinimumVersion-1.20-10pclos2011.noarch.rpm Find a minimum required version of perl for Perl code
perl-Perl-OSType-1.009-1pclos2016.noarch.rpm Map Perl operating system names to generic types
perl-Perl-Version-1.009-10pclos2011.noarch.rpm Parse and manipulate Perl version strings
perl-Perl6-Doc-0.45-10pclos2011.noarch.rpm Perl 6 Documentation Collection
perl-Perl6-Export-0.07-10pclos2011.noarch.rpm Implements the Perl 6 is export trait
perl-Perl6-Export-Attrs-0.0.3-10pclos2011.noarch.rpm The Perl 6 'is export(...)' trait as a Perl 5 attribute
perl-Perl6-Junction-1.40000-10pclos2011.noarch.rpm Perl6 style Junction operators in Perl5
perl-Perl6-Perldoc-0.0.5-10pclos2011.noarch.rpm Add a to_xhtml() method to Perl6::Perldoc::Parser
perl-Perl6-Perldoc-To-Ansi-0.10-10pclos2011.noarch.rpm ANSI-colored text renderer for Perl6::Perldoc
perl-Perl6-Signature-0.03-10pclos2011.noarch.rpm Parse, query, and pretty-print Perl 6 signatures
perl-Perl6-Slurp-0.03-10pclos2011.noarch.rpm Implements the Perl 6 'slurp' built-in
perl-PerlIO-eol-0.14-10pclos2011.x86_64.rpm PerlIO layer for normalizing line endings
Advertisement
Advertisement