ruby-2.1.2-1pclos2014.x86_64.rpm


Advertisement

Description

ruby - An interpreter of object-oriented scripting language

Property Value
Distribution PCLinuxOS
Repository PCLinuxOS x86_64
Package name ruby
Package version 2.1.2
Package release 1pclos2014
Package architecture x86_64
Package type rpm
Installed size 2.34 MB
Download size 2.34 MB
Official Mirror ftp.nluug.nl
Ruby is the interpreted scripting language for quick and easy
object-oriented programming.  It has many features to process text
files and to do system management tasks (as in Perl).  It is simple,
straight-forward, and extensible.

Alternatives

Package Version Architecture Repository
ruby - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libruby.so.2.1()(64bit) -
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsLzma) <= 4.4.6-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rtld(GNU_HASH) -
ruby(rubygems) >= 2.2.2
ruby-libs(x86-64) = 2.1.2-1pclos2014
rubygem(bigdecimal) >= 1.2.4

Provides

Name Value
ruby = 2.1.2-1pclos2014
ruby(runtime_executable) = 2.1.2
ruby(x86-64) = 2.1.2-1pclos2014

Obsoletes

Name Value
lib64qtruby4shared2 <= 4.10.1-1
marisa-ruby <= 0.2.4-1
pdflib-lite-ruby <= 7.0.5-3
ruby <= 1.8.7.p352-2
ruby-Ascii85 <= 1.0.0-1
ruby-Ascii85-doc <= 1.0.0-1
ruby-BlueCloth <= 1.0.1-1
ruby-BlueCloth-doc <= 1.0.1-1
ruby-RedCloth <= 4.2.7-1
ruby-RedCloth-doc <= 4.2.7-1
ruby-RubyGems <= 1.7.2-1
ruby-RubyInline <= 3.8.6-1
ruby-RubyInline-doc <= 3.8.6-1
ruby-SDL <= 2.0.1-1
ruby-SystemTimer <= 1.2.2-1
ruby-SystemTimer-doc <= 1.2.2-1
ruby-ZenTest <= 4.5.0-1
ruby-ZenTest-doc <= 4.5.0-1
ruby-abstract <= 1.0.0-1
ruby-abstract-doc <= 1.0.0-1
ruby-actionmailer <= 2.3.11-1
ruby-actionpack <= 2.3.11-1
ruby-activerecord <= 3.1.0-1
ruby-activeresource <= 2.3.11-1
ruby-activesupport <= 3.1.0-1
ruby-allison <= 2.0.3-1
ruby-allison-doc <= 2.0.3-1
ruby-amazon <= 0.9.2-1
ruby-archive-tar-minitar <= 0.5.2-1
ruby-archive-tar-minitar-doc <= 0.5.2-1
ruby-atk <= 1.0.3-1
ruby-atk-devel <= 1.0.3-1
ruby-atk-doc <= 1.0.3-1
ruby-autotest <= 4.2.9-1
ruby-autotest-doc <= 4.2.9-1
ruby-background_process <= 1.2-1
ruby-background_process-doc <= 1.2-1
ruby-bdb <= 0.6.5-1
ruby-builder <= 2.1.2-1
ruby-builder-doc <= 2.1.2-1
ruby-caca <= 0.99-0.beta16.3
ruby-cairo <= 1.10.0-1
ruby-cairo-doc <= 1.10.0-1
ruby-cancan <= 1.2.0-1
ruby-cancan-doc <= 1.2.0-1
ruby-choices <= 0.2.0-1
ruby-choices-doc <= 0.2.0-1
ruby-chronic <= 0.3.0-1
ruby-chronic-doc <= 0.3.0-1
ruby-ci_reporter <= 1.6.4-1
ruby-ci_reporter-doc <= 1.6.4-1
ruby-coderay <= 0.9.7-1
ruby-coderay-doc <= 0.9.7-1
ruby-coffee-script <= 2.1.2-1
ruby-coffee-script-doc <= 2.1.2-1
ruby-coffee-script-source <= 1.0.1-1
ruby-coffee-script-source-doc <= 1.0.1-1
ruby-columnize <= 0.3.2-1
ruby-columnize-doc <= 0.3.2-1
ruby-configuration <= 1.1.0-1
ruby-configuration-doc <= 1.1.0-1
ruby-contest <= 0.1.2-1
ruby-contest-doc <= 0.1.2-1
ruby-crack <= 0.1.8-1
ruby-crack-doc <= 0.1.8-1
ruby-cucumber <= 0.10.2-1
ruby-cucumber-doc <= 0.10.2-1
ruby-culerity <= 0.2.15-1
ruby-culerity-doc <= 0.2.15-1
ruby-curb <= 0.7.15-1
ruby-curb-doc <= 0.7.15-1
ruby-daemons <= 1.1.2-1
ruby-daemons-doc <= 1.1.2-1
ruby-database_cleaner <= 0.5.2-1
ruby-database_cleaner-doc <= 0.5.2-1
ruby-dbd-mysql <= 0.4.4-1
ruby-dbd-mysql-doc <= 0.4.4-1
ruby-dbd-sqlite3 <= 1.2.5-1
ruby-dbd-sqlite3 <= doc-1.2.5-1
ruby-dbi <= 0.4.5-1
ruby-dbi-doc <= 0.4.5-1
ruby-deprecated <= 2.0.1-1
ruby-devel <= 1.8.7.p352-2
ruby-dict <= 0.9.4-1
ruby-diff-lcs <= 1.1.2-1
ruby-diff-lcs-doc <= 1.1.2-1
ruby-doc <= 1.8.7.p352-2
ruby-dust <= 0.1.6-1
ruby-dust-doc <= 0.1.6-1
ruby-echoe <= 4.5.6-1
ruby-echoe-doc <= 4.5.6-1
ruby-edavis10-object_daddy <= 0.4.3-1
ruby-em-http-request <= 0.3.0-1
ruby-em-http-request-doc <= 0.3.0-1
ruby-erubis <= 2.7.0-1
ruby-erubis-doc <= 2.7.0-1
ruby-escape_utils <= 0.2.3-1
ruby-escape_utils-doc <= 0.2.3-1
ruby-eventmachine <= 0.12.10-1
ruby-eventmachine-doc <= 0.12.10-1
ruby-factory_girl <= 1.2.4-1
ruby-factory_girl-doc <= 1.2.4-1
ruby-faker <= 0.3.1-1
ruby-faker-doc <= 0.3.1-1
ruby-fakeweb <= 1.3.0-1
ruby-fakeweb-doc <= 1.3.0-1
ruby-faraday <= 0.6.1-1
ruby-faraday-doc <= 0.6.1-1
ruby-fastercsv <= 1.5.4-1
ruby-fastercsv-doc <= 1.5.4-1
ruby-fastthread <= 1.0.7-1
ruby-fastthread-doc <= 1.0.7-1
ruby-fb <= 0.6.7-1
ruby-fb-doc <= 0.6.7-1
ruby-fb_adapter <= 0.6.0-1
ruby-fb_adapter-doc <= 0.6.0-1
ruby-fcgi <= 0.8.8-1
ruby-ffi <= 1.0.7-1
ruby-ffi-doc <= 1.0.7-1
ruby-flexmock <= 0.9.0-1
ruby-flexmock-doc <= 0.9.0-1
ruby-fssm <= 0.1.4-1
ruby-fssm-doc <= 0.1.4-1
ruby-gd <= 0.8.0-1
ruby-gdk_pixbuf2 <= 1.0.3-1
ruby-gdk_pixbuf2-doc <= 1.0.3-1
ruby-gem2rpm <= 0.6.0-1
ruby-gem_plugin <= 0.2.3-1
ruby-gem_plugin-doc <= 0.2.3-1
ruby-gemcutter <= 0.7.0-1
ruby-gemcutter-doc <= 0.7.0-1
ruby-geoip <= 1.0.0-1
ruby-geoip-doc <= 1.0.0-1
ruby-gettext <= 2.1.0-1
ruby-gettext-doc <= 2.1.0-1
ruby-git <= 1.2.5-1
ruby-git-doc <= 1.2.5-1
ruby-glib2 <= 1.0.3-1
ruby-glib2-devel <= 1.0.3-1
ruby-glib2-doc <= 1.0.3-1
ruby-graphviz <= 2.36.0-1
ruby-gtk2 <= 1.0.3-1
ruby-gtk2-devel <= 1.0.3-1
ruby-gtk2-doc <= 1.0.3-1
ruby-hoe <= 2.9.4-1
ruby-hoe-doc <= 2.9.4-1
ruby-hoe-gemspec <= 1.0.0-1
ruby-hoe-gemspec-doc <= 1.0.0-1
ruby-hoe-git <= 1.3.0-1
ruby-hoe-git-doc <= 1.3.0-1
ruby-htmlentities <= 4.2.4-1
ruby-htmlentities-doc <= 4.2.4-1
ruby-httpclient <= 2.2.0-1
ruby-httpclient-doc <= 2.2.0-1
ruby-i18n <= 0.4.2-1
ruby-i18n-doc <= 0.4.2-1
ruby-icalendar <= 1.1.6-1
ruby-icalendar-doc <= 1.1.6-1
ruby-isolate <= 3.0.0-1
ruby-isolate-doc <= 3.0.0-1
ruby-itextomml <= 1.4.5-1
ruby-itextomml-doc <= 1.4.5-1
ruby-jeweler <= 1.5.2-1
ruby-jeweler-doc <= 1.5.2-1
ruby-json <= 1.2.0-1
ruby-json_pure <= 1.5.1-1
ruby-json_pure-doc <= 1.5.1-1
ruby-launchy <= 0.3.7-1
ruby-launchy-doc <= 0.3.7-1
ruby-less <= 1.2.21-1
ruby-less-doc <= 1.2.21-1
ruby-libxml <= 1.1.3-1
ruby-libxml-doc <= 1.1.3-1
ruby-linecache <= 0.43-1
ruby-linecache-doc <= 0.43-1
ruby-liquid <= 2.2.2-1
ruby-liquid-doc <= 2.2.2-1
ruby-locale <= 2.0.5-1
ruby-locale-doc <= 2.0.5-1
ruby-log4r <= 1.1.9-1
ruby-log4r-doc <= 1.1.9-1
ruby-markaby <= 0.7.1-1
ruby-markaby-doc <= 0.7.1-1
ruby-maruku <= 0.6.0-1
ruby-maruku-doc <= 0.6.0-1
ruby-mg <= 0.0.8-1
ruby-minitest <= 2.1.0-1
ruby-minitest-doc <= 2.1.0-1
ruby-mocha <= 0.9.12-1
ruby-mocha-doc <= 0.9.12-1
ruby-mongrel <= 1.2.0-0.pre2.1
ruby-mongrel-doc <= 1.2.0-0.pre2.1
ruby-multi_json <= 0.0.5-1
ruby-multi_json-doc <= 0.0.5-1
ruby-mutter <= 0.5.3-1
ruby-mutter-doc <= 0.5.3-1
ruby-ncurses <= 1.2.2-1
ruby-net-ldap <= 0.2.2-1
ruby-net-ldap-doc <= 0.2.2-1
ruby-net-sftp <= 2.0.5-1
ruby-net-sftp-doc <= 2.0.5-1
ruby-net-ssh <= 2.1.4-1
ruby-net-ssh-doc <= 2.1.4-1
ruby-newgem <= 1.5.3-1
ruby-newgem-doc <= 1.5.3-1
ruby-oa-basic <= 0.2.2-1
ruby-oa-basic-doc <= 0.2.2-1
ruby-oa-enterprise <= 0.2.2-1
ruby-oa-enterprise-doc <= 0.2.2-1
ruby-oa-more <= 0.2.2-1
ruby-oa-more-doc <= 0.2.2-1
ruby-oa-openid <= 0.2.2-1
ruby-oa-openid-doc <= 0.2.2-1
ruby-obexftp <= 0.23-6
ruby-omniauth <= 0.2.2-1
ruby-omniauth-doc <= 0.2.2-1
ruby-oniguruma <= 1.1.0-1
ruby-oniguruma-doc <= 1.1.0-1
ruby-open4 <= 0.9.6-1
ruby-open4-doc <= 0.9.6-1
ruby-openbabel <= 2.3.2-2
ruby-openid-apps-discovery <= 1.2.0-1
ruby-openid-apps-discovery-doc <= 1.2.0-1
ruby-pango <= 1.0.3-1
ruby-pango-devel <= 1.0.3-1
ruby-pango-doc <= 1.0.3-1
ruby-patron <= 0.4.11-1
ruby-patron-doc <= 0.4.11-1
ruby-pdf-reader <= 0.9.1-1
ruby-pdf-reader-doc <= 0.9.1-1
ruby-pkg-config <= 1.1.0-1
ruby-pkg-config-doc <= 1.1.0-1
ruby-polyglot <= 0.3.1-1
ruby-polyglot-doc <= 0.3.1-1
ruby-prawn-core <= 0.8.4-1
ruby-prawn-core-doc <= 0.8.4-1
ruby-prelude <= 1.0.1-1
ruby-progressbar <= 0.9-1
ruby-protest <= 0.4.2-1
ruby-protest-doc <= 0.4.2-1
ruby-pyu-ruby-sasl <= 0.0.3.2-1
ruby-pyu-ruby-sasl-doc <= 0.0.3.2-1
ruby-racc <= 1.4.5-1
ruby-rack <= 1.1.2-1
ruby-rack-doc <= 1.1.2-1
ruby-rack-openid <= 1.2.0-1
ruby-rack-openid-doc <= 1.2.0-1
ruby-rack-test <= 0.5.7-1
ruby-rack-test-doc <= 0.5.7-1
ruby-radius <= 0.6.1-1
ruby-radius-doc <= 0.6.1-1
ruby-rails <= 2.3.11-1
ruby-rails-devel <= 2.3.11-1
ruby-rails-doc <= 2.3.11-1
ruby-rake <= 0.8.7-1
ruby-rake-compiler <= 0.7.7-1
ruby-rake-compiler-doc <= 0.7.7-1
ruby-rbogl <= 0.32g-1
ruby-rchardet <= 1.3-1
ruby-rchardet-doc <= 1.3-1
ruby-rcov <= 0.9.9-1
ruby-rcov-doc <= 0.9.9-1
ruby-rdiscount <= 1.3.1.1-1
ruby-rdiscount-doc <= 1.3.1.1-1
ruby-rdoc <= 3.5.3-1
ruby-rdoc-doc <= 3.5.3-1
ruby-redgreen <= 1.2.2-1
ruby-rest-client <= 1.6.1-1
ruby-rest-client-doc <= 1.6.1-1
ruby-rexical <= 1.0.5-1
ruby-rexical-doc <= 1.0.5-1
ruby-riddle <= 1.2.2-1
ruby-riddle-doc <= 1.2.2-1
ruby-ritex <= 1.0.1-1
ruby-ritex-doc <= 1.0.1-1
ruby-rpm <= 1.2.3-12
ruby-rr <= 1.0.2-1
ruby-rr-doc <= 1.0.2-1
ruby-rspec <= 2.5.0-1
ruby-rspec-core <= 2.5.0-1
ruby-rspec-core-doc <= 2.5.0-1
ruby-rspec-doc <= 2.5.0-1
ruby-rspec-expectations <= 2.5.0-1
ruby-rspec-expectations-doc <= 2.5.0-1
ruby-rspec-mocks <= 2.5.0-1
ruby-rspec-mocks-doc <= 2.5.0-1
ruby-rubigen <= 1.5.6-1
ruby-rubigen-doc <= 1.5.6-1
ruby-ruby-debug <= 0.10.4-1
ruby-ruby-debug-base <= 0.10.4-1
ruby-ruby-debug-base-doc <= 0.10.4-1
ruby-ruby-debug-doc <= 0.10.4-1
ruby-ruby-openid <= 2.1.8-1
ruby-ruby-openid-doc <= 2.1.8-1
ruby-rubyntlm <= 0.1.1-1
ruby-rubyntlm-doc <= 0.1.1-1
ruby-rubyzip <= 0.9.4-1
ruby-rubyzip-doc <= 0.9.4-1
ruby-rvm <= 1.6.3-1
ruby-rvm-doc <= 1.6.3-1
ruby-sary <= 1.2.0-8
ruby-sexp_processor <= 3.0.5-1
ruby-sexp_processor-doc <= 3.0.5-1
ruby-shotgun <= 0.8-1
ruby-shotgun-doc <= 0.8-1
ruby-shoulda <= 2.10.3-1
ruby-shoulda-doc <= 2.10.3-1
ruby-simplecov-html <= 0.4.4-1
ruby-simplecov-html-doc <= 0.4.4-1
ruby-sprockets <= 1.0.2-1
ruby-sprockets-doc <= 1.0.2-1
ruby-sprockets-rails <= 0.0.1-1
ruby-sprockets-rails-doc <= 0.0.1-1
ruby-sqlite3 <= 1.3.3-1
ruby-sqlite3-doc <= 1.3.3-1
ruby-stomp <= 1.1.7-1
ruby-stomp-doc <= 1.1.7-1
ruby-strace_me <= 1.0-1
ruby-strace_me-doc <= 1.0-1
ruby-svn <= 1.8.10-1
ruby-syntax <= 1.0.0-1
ruby-syntax-doc <= 1.0.0-1
ruby-term-ansicolor <= 1.0.5-1
ruby-term-ansicolor-doc <= 1.0.5-1
ruby-test-construct <= 1.2.0-1
ruby-test-construct-doc <= 1.2.0-1
ruby-test-spec <= 0.10.0-1
ruby-test-spec-doc <= 0.10.0-1
ruby-test-unit <= 2.1.2-1
ruby-test-unit-doc <= 2.1.2-1
ruby-text-format <= 1.0.0-1
ruby-text-format-doc <= 1.0.0-1
ruby-text-hyphen <= 1.0.2-1
ruby-text-hyphen-doc <= 1.0.2-1
ruby-thrift <= 0.5.0-1
ruby-thrift-doc <= 0.5.0-1
ruby-tidy_ffi <= 0.1.3-1
ruby-tidy_ffi-doc <= 0.1.3-1
ruby-tk <= 1.8.7.p352-2
ruby-tmail <= 1.2.7-1
ruby-tmail-doc <= 1.2.7-1
ruby-treetop <= 1.4.9-1
ruby-treetop-doc <= 1.4.9-1
ruby-typhoeus <= 0.2.4-1
ruby-typhoeus-doc <= 0.2.4-1
ruby-tzinfo <= 0.3.26-1
ruby-tzinfo-doc <= 0.3.26-1
ruby-validates_email_format_of <= 1.4.5-1
ruby-vestal_versions <= 1.0.2-1
ruby-vestal_versions-doc <= 1.0.2-1
ruby-webmock <= 1.6.2-1
ruby-webmock-doc <= 1.6.2-1
ruby-whenever <= 0.4.2-1
ruby-whenever-doc <= 0.4.2-1
ruby-will_paginate <= 2.3.15-1
ruby-will_paginate-doc <= 2.3.15-1
ruby-wrongdoc <= 1.5.0-1
ruby-wrongdoc-doc <= 1.5.0-1
ruby-xml-simple <= 1.0.15-1
ruby-xml-simple-doc <= 1.0.15-1
ruby-yadis <= 0.3.4-1
ruby-yadis-doc <= 0.3.4-1
ruby-yard <= 0.6.8-1
ruby-yard-doc <= 0.6.8-1
ruby-zoom <= 0.4.1-1
rubygem-minitest <= 2.5.1-1
rubygem-rake <= 0.9.2-1
rubygem-rake-doc <= 0.9.2-1
rubygem-rubyforge <= 2.0.4-1
weechat-ruby <= 0.4.0-2
xmms2-ruby <= 0.8-2

Download

Type URL
Binary Package ruby-2.1.2-1pclos2014.x86_64.rpm
Source Package ruby-2.1.2-1pclos2014.src.rpm

Install Howto

  1. Enable PCLinuxOS x86_64 repository in /etc/apt/sources.list:
    rpm http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/ pclinuxos/64bit x86_64
  2. Update the package index:
    # apt-get update
  3. Install ruby rpm package:
    # apt-get install ruby

See Also

Package Description
ruby-devel-2.1.2-1pclos2014.x86_64.rpm A Ruby development environment
ruby-doc-2.1.2-1pclos2014.noarch.rpm Documentation for ruby
ruby-irb-2.1.2-1pclos2014.noarch.rpm The Interactive Ruby
ruby-libs-2.1.2-1pclos2014.x86_64.rpm Libraries necessary to run Ruby
ruby-openbabel-2.3.2-3pclos2015.x86_64.rpm Ruby wrapper for the Open Babel library
ruby-sary-1.2.0-9pclos2014.x86_64.rpm Ruby Binding of Sary
ruby-shadow-1.4.1-1pclos2014.x86_64.rpm Ruby bindings for shadow password access
ruby-svn-1.8.10-2pclos2014.x86_64.rpm Ruby bindings for Subversion
ruby-tcltk-2.1.2-1pclos2014.x86_64.rpm Tcl/Tk interface for scripting language Ruby
rubygem-Ascii85-1.0.2-1pclos2014.noarch.rpm Methods to encode/decode Adobe's binary-to-text encoding of the same name
rubygem-Ascii85-doc-1.0.2-1pclos2014.noarch.rpm Documentation for rubygem-Ascii85
rubygem-ZenTest-4.10.0-1pclos2014.noarch.rpm Automated test scaffolding for Ruby
rubygem-ZenTest-doc-4.10.0-1pclos2014.noarch.rpm Documentation for rubygem-ZenTest
rubygem-actionmailer-4.1.5-1pclos2014.noarch.rpm Service layer for easy email delivery and testing
rubygem-actionmailer-doc-4.1.5-1pclos2014.noarch.rpm Documentation for rubygem-actionmailer
Advertisement
Advertisement