lib64tqt3-mt-devel-3.5.0-14.0.5_1.pclos2018.x86_64.rpm


Advertisement

Description

lib64tqt3-mt-devel - TQt development files (Threaded)

Property Value
Distribution PCLinuxOS
Repository Trinity R14 x86_64
Package name lib64tqt3-mt-devel
Package version 3.5.0
Package release 14.0.5_1.pclos2018
Package architecture x86_64
Package type rpm
Installed size 2.03 MB
Download size 2.03 MB
Official Mirror ftp.fau.de
TQt is a C++ class library optimized for graphical user interface
development. This package contains the libtqt-mt.so symlink, necessary
for building threaded TQt applications as well as the libtqui.so symlink
and the necessary header files for libtqui.so. (See README.Debian and
the TQt Documentation for instructions on libtqui.so)
WARNING: If you plan to build some older TQt3 applications, you will
most probably have to install the tqt3-compat-headers package. It
contains all the headers which are not part of the official TQt3 API
anymore but which are still used by some programs. So if you encounter
problems with missing header files, please install this package first
before you send a bugreport.

Alternatives

Package Version Architecture Repository
lib64tqt3-mt-devel - - -

Requires

Name Value
devel(libICE(64bit)) -
devel(libSM(64bit)) -
devel(libX11(64bit)) -
devel(libXcursor(64bit)) -
devel(libXext(64bit)) -
devel(libXft(64bit)) -
devel(libXi(64bit)) -
devel(libXinerama(64bit)) -
devel(libXrandr(64bit)) -
devel(libXrender(64bit)) -
devel(libXt(64bit)) -
devel(libaudio(64bit)) -
devel(libdl(64bit)) -
devel(libfontconfig(64bit)) -
devel(libfreetype(64bit)) -
devel(libgcc_s(64bit)) -
devel(libglib-2.0(64bit)) -
devel(libgthread-2.0(64bit)) -
devel(libjpeg(64bit)) -
devel(libm(64bit)) -
devel(libpng16(64bit)) -
devel(libstdc++(64bit)) -
devel(libtqt-mt(64bit)) -
devel(libuuid(64bit)) -
devel(libz(64bit)) -
fontconfig-devel -
freetype-devel -
glib2-devel -
glibc-devel -
lib64tqt3-mt = 3.5.0-14.0.5_1.pclos2018
lib64xrandr2-devel -
libice-devel -
libjpeg-devel -
libpng-devel -
libsm-devel -
libuuid-devel -
libx11-devel -
libxcursor-devel -
libxext-devel -
libxft-devel -
libxi-devel -
libxinerama-devel -
libxrender-devel -
nas-devel -
pkgconfig -
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rpmlib(VersionedDependencies) <= 3.0.3-1
zlib-devel -

Provides

Name Value
devel(libtqt-mt(64bit)) -
devel(libtqui(64bit)) -
lib64tqt3-mt-devel = 3.5.0-14.0.5_1.pclos2018
lib64tqt3-mt-devel(x86-64) = 3.5.0-14.0.5_1.pclos2018
libtqt3-mt-devel = 3.5.0-14.0.5_1.pclos2018
pkgconfig(tqt-mt) = 3.5
trinity-tqt3-devel = 3.5.0-14.0.5_1.pclos2018

Download

Type URL
Binary Package lib64tqt3-mt-devel-3.5.0-14.0.5_1.pclos2018.x86_64.rpm
Source Package trinity-tqt3-3.5.0-14.0.5_1.pclos2018.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    http://mirror.ppa.trinitydesktop.org/trinity/trinity/rpm/pclinuxos/ trinity-r14/RPMS x86_64
  2. Update the package index:
    # sudo apt-get update
  3. Install lib64tqt3-mt-devel rpm package:
    # sudo apt-get install lib64tqt3-mt-devel

See Also

Package Description
lib64tqt3-mt-ibase-3.5.0-14.0.5_1.pclos2018.x86_64.rpm InterBase/FireBird database driver for TQt3 (Threaded)
lib64tqt3-mt-mysql-3.5.0-14.0.5_1.pclos2018.x86_64.rpm MySQL database driver for TQt3 (Threaded)
lib64tqt3-mt-odbc-3.5.0-14.0.5_1.pclos2018.x86_64.rpm ODBC database driver for TQt3 (Threaded)
lib64tqt3-mt-psql-3.5.0-14.0.5_1.pclos2018.x86_64.rpm PostgreSQL database driver for TQt3 (Threaded)
lib64tqt3-mt-sqlite-3.5.0-14.0.5_1.pclos2018.x86_64.rpm SQLite database driver for TQt3 (Threaded)
lib64tqt3-mt-sqlite3-3.5.0-14.0.5_1.pclos2018.x86_64.rpm SQLite3 database driver for TQt3 (Threaded)
lib64tqt3-mt-tqca-tls-1.0-14.0.5_1.pclos2018.x86_64.rpm TLS plugin for the TQt Cryptographic Architecture
lib64tqt4-4.2.0-14.0.5_1.pclos2018.x86_64.rpm The Trinity Qt Interface Libraries
lib64tqt4-devel-4.2.0-14.0.5_1.pclos2018.x86_64.rpm The Trinity Qt Interface Libraries (Development Files)
perl-TQt-3.008-14.0.5_1.pclos2018.x86_64.rpm Perl bindings for the TQt library
perl-dcop-14.0.5-1.pclos2018.x86_64.rpm DCOP Bindings for Perl
python-dcop-14.0.5-1.pclos2018.x86_64.rpm DCOP bindings for Python
python-tqt-3.18.1-14.0.5_1.pclos2018.x86_64.rpm TQt bindings for Python
python-tqt-devel-3.18.1-14.0.5_1.pclos2018.x86_64.rpm TQt bindings for Python - Development files
python-tqt-gl-3.18.1-14.0.5_1.pclos2018.x86_64.rpm TQt OpenGL bindings for Python
Advertisement
Advertisement